Group buy of EH Bad Stone Phase Shift boards

Looking for a particular component or hardware part and you just cannot find it? Got comoonents surplus and want to get rid of it? Post it all here... No sales of working pedals, put these in the 'Seen for sale' section please.

Re: Group buy of EH Bad Stone Phase Shift boards

Postby greenskull » 14 Feb 2011, 09:56

SUCCESS AT LAST!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Scruffie can get to bed early tonight.
I had a goddamn 100k resistor at the R50 spot!
Everything works even the manual pot (with trace cut).
Pots are backwards and it really needs a volume boost (will solder in LPB circuit tomorrow), but it's good to go. I'll try not stink up this thread with my debugging adventures while trying to fix my first board attempt next, haha!!
Over and out and many thanks for all who worked on getting this great project/board together.
fuck smooth tone, fuck eric johnson - Seiche
User avatar
greenskull
Resistor Ronker
 
Posts: 261
Joined: 03 Jul 2007, 23:47
Has thanked: 37 times
Have thanks: 9 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Scruffie » 14 Feb 2011, 17:51

greenskull wrote:SUCCESS AT LAST!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Scruffie can get to bed early tonight.
I had a goddamn 100k resistor at the R50 spot!
Everything works even the manual pot (with trace cut).
Pots are backwards and it really needs a volume boost (will solder in LPB circuit tomorrow), but it's good to go. I'll try not stink up this thread with my debugging adventures while trying to fix my first board attempt next, haha!!
Over and out and many thanks for all who worked on getting this great project/board together.

Haha, yeahh... a 100k in that spot'd do it.

Glad you got it all working now, including that Manual control.

Get that volume boost going, I don't think anyone else has yet :thumbsup
Scruffie
Opamp Operator
 
Posts: 1739
Joined: 13 Mar 2009, 18:59
Location: London.. ish, Uk
Has thanked: 27 times
Have thanks: 139 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby phibes » 15 Feb 2011, 06:33

Scruffie never sleeps! :popcorn:
GuitarlCarl - "TGP = The Gear Polishers"

Image Ken
User avatar
phibes
Transistor Tuner
 
Posts: 1107
Joined: 10 Dec 2008, 02:17
Location: United States
Has thanked: 85 times
Have thanks: 185 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby greenskull » 15 Feb 2011, 07:26

AAAAHHHHHH!! IBefore I soldered in the LPB parts I took out my trusty meter to see how the LPB circuit pads were connected on the board...... a big problem there!

There is an incorrect connection from the wrong side of R52 causing a short at the outside of LPB input cap and base of tranny.
Also the power connection needs to be flipped to the other side of R50 to get full voltage. While we are at it, R53 needs to be rerouted other side of R50.
Maybe use a 47k for R48 and 470K for R52 to match the orignal LPB-1 schematic (43K & 430K) .... not the big problem, though.
Check the board pads with your meter and you'll see what I'm talking about. Hope it helps someone!
fuck smooth tone, fuck eric johnson - Seiche
User avatar
greenskull
Resistor Ronker
 
Posts: 261
Joined: 03 Jul 2007, 23:47
Has thanked: 37 times
Have thanks: 9 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby azrael » 15 Feb 2011, 07:30

Crap! Switched around Q1. Still nada. Nothing. Zip. Zilch. :(

My voltage readings are still off for the opamps, despite some swapping. Pin 8 is around 5.6V instead of 7ish, and around 2.7V instead of 3.6V.

I'm going to go write down the readings just to be sure.

I have the manual pot hooked up, no trace cut. I have the LPB hooked, but I tried audio probing at the normal output, and still nothing.

Ideas?
User avatar
azrael
Cap Cooler
 
Posts: 574
Joined: 02 Jun 2009, 15:07
Has thanked: 33 times
Have thanks: 93 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby greenskull » 15 Feb 2011, 09:47

azrael wrote:Crap! Switched around Q1. Still nada. Nothing. Zip. Zilch. :(

My voltage readings are still off for the opamps, despite some swapping. Pin 8 is around 5.6V instead of 7ish, and around 2.7V instead of 3.6V.

I'm going to go write down the readings just to be sure.

I have the manual pot hooked up, no trace cut. I have the LPB hooked, but I tried audio probing at the normal output, and still nothing.

Ideas?


maybe make sure your resistors are in the right positions with the layout Duckman posted on the previous page.... I messed up my first board with mixing up a couple of vertical resistors that I soldered in the wrong place. If you know for sure the components are the right values I would then check for bridges, but that's probably unlikely due to the solder mask. Also never hurts to reflow everything in case of cold joints.... worth a try. It took me two tries to get one working, so good luck!!
fuck smooth tone, fuck eric johnson - Seiche
User avatar
greenskull
Resistor Ronker
 
Posts: 261
Joined: 03 Jul 2007, 23:47
Has thanked: 37 times
Have thanks: 9 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Duckman » 15 Feb 2011, 09:48

greenskull wrote:AAAAHHHHHH!! IBefore I soldered in the LPB parts I took out my trusty meter to see how the LPB circuit pads were connected on the board...... a big problem there!

There is an incorrect connection from the wrong side of R52 causing a short at the outside of LPB input cap and base of tranny.
Also the power connection needs to be flipped to the other side of R50 to get full voltage. While we are at it, R53 needs to be rerouted other side of R50.
Maybe use a 47k for R48 and 470K for R52 to match the orignal LPB-1 schematic (43K & 430K) .... not the big problem, though.
Check the board pads with your meter and you'll see what I'm talking about. Hope it helps someone!


Dammit! You're right about R52! There's main voltage on the wrong point! Need to cut traces between R52/R48 and between R52 / Q2 base to reconnect it. About R50, it's in the original BS schemo, but if you need full 9v, put a jumper on it
User avatar
Duckman
Opamp Operator
 
Posts: 1512
Joined: 20 May 2009, 02:45
Has thanked: 368 times
Have thanks: 126 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby greenskull » 15 Feb 2011, 11:01

Hi Duckman - Glad to help solve a problem! Sorry, I use to many words sometimes.... I mean the LPB circuit should be on other side of R50 to get full 9v power. maybe it doesn't matter anyway.
Another question is why the 100k/1M divider values chosen instead of 47k/470k (43k/430k on original)? A better change in sound?
fuck smooth tone, fuck eric johnson - Seiche
User avatar
greenskull
Resistor Ronker
 
Posts: 261
Joined: 03 Jul 2007, 23:47
Has thanked: 37 times
Have thanks: 9 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Scruffie » 15 Feb 2011, 17:00

Well... if it didn't need Track Side adjustments, it just wouldn't be an EHX Pedal :mrgreen:

Seriously though... that's a bit annoying but i'll write up some updated information to solve the Manual & LPB issues, a bit of a pain but that's what you get for adding without prototyping (Although the Manual pot would have required a Jumper anyway and i'd rather the main Bad Stone board not have jumpers... so that was just missing information from the mods document).

Regards... the LPB voltage, it'll be fine off the lower voltage i'd imagine, I suppose it could be an idea to drop the value of the 100R Resistor to 47R but I haven't really experimented with that, I do know that B Tremblay posted that the voltages from his actual Bad Stone were simmilar so there must be some reason they decided to drop the voltage a bit (There's several incarnations of this pedal, some bipolar, some with FETs, it's easy to loose track).

greenskull wrote:
While we are at it, R53 needs to be rerouted other side of R50.


I don't see any issue with R53 though, why does it need rerouting?

greenskull wrote:
Another question is why the 100k/1M divider values chosen instead of 47k/470k (43k/430k on original)? A better change in sound?

It's not crucial, it just depends what schematic you go off, 100k/1M will work fine but if you wanna have 47k/470k or 43k/430k it'll work too.

Duckman wrote:Dammit! You're right about R52! There's main voltage on the wrong point! Need to cut traces between R52/R48 and between R52 / Q2 base to reconnect it.

Hmm, it'll take more than that otherwise R52 is just hanging and as is R48... i'll have to think of an easy work around.

Dear oh dear... Appologies everyone :oops:
Scruffie
Opamp Operator
 
Posts: 1739
Joined: 13 Mar 2009, 18:59
Location: London.. ish, Uk
Has thanked: 27 times
Have thanks: 139 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Scruffie » 15 Feb 2011, 17:03

azrael wrote:Crap! Switched around Q1. Still nada. Nothing. Zip. Zilch. :(

My voltage readings are still off for the opamps, despite some swapping. Pin 8 is around 5.6V instead of 7ish, and around 2.7V instead of 3.6V.

I'm going to go write down the readings just to be sure.

I have the manual pot hooked up, no trace cut. I have the LPB hooked, but I tried audio probing at the normal output, and still nothing.

Ideas?

Right... Cut the Manual Pot Trace, Go from the Bad Stone main output for the moment.

If the voltages are all in the right zone, only low, then try changing your R50 resistor, as we've just learnt from greenskulls 100k, it can bring everything down so perhaps its tollerance is off or something.

Did you check your Q2 pinout from the correct datasheet before swapping?

Please post all your Voltages though yes, that'll give something to look at and check all your resistor values are correct.
Scruffie
Opamp Operator
 
Posts: 1739
Joined: 13 Mar 2009, 18:59
Location: London.. ish, Uk
Has thanked: 27 times
Have thanks: 139 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Barcode » 15 Feb 2011, 17:15

So are we saying there are actual issues with the LPB section on the board? If so that would make me feel a heck of a lot better about it not functioning for me...
User avatar
Barcode
Diode Debunker
 
Posts: 821
Joined: 27 Sep 2007, 18:03
Has thanked: 14 times
Have thanks: 35 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Scruffie » 15 Feb 2011, 17:17

Barcode wrote:So are we saying there are actual issues with the LPB section on the board? If so that would make me feel a heck of a lot better about it not functioning for me...

Yes I beleive so, you can breath a sigh of relief, then shout at me :oops:

The actual Bad Stone is sound though, so anyone having problems with that... that's just unfortunate.
Scruffie
Opamp Operator
 
Posts: 1739
Joined: 13 Mar 2009, 18:59
Location: London.. ish, Uk
Has thanked: 27 times
Have thanks: 139 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Duckman » 15 Feb 2011, 20:09

Sorry Scruffie and you, all guys, about this.
Maybe I wrote a little fast yesterday and now I'm awake with a more freshly brain to explain more claearly.
First of all, we need to cut R52/R48 and R52/Q2 base traces, to prevent main voltage acces to Q2 and R48. After that we need to reconnect both to the right side of R52, wich can stay in place, as long as it need yet to be feeded with main voltage. Two little wires can do the job; one from "cutted" side of R48 and one from Q2 base, both connected to the right side of R52.
Now you got a nice aproach to an EH classic job!! :thumbsup ... :oops: sorry... maybe the joke it's out of place... but I can't resist!
User avatar
Duckman
Opamp Operator
 
Posts: 1512
Joined: 20 May 2009, 02:45
Has thanked: 368 times
Have thanks: 126 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby greenskull » 15 Feb 2011, 23:13

Thanks Duckman, I will give it a shot tonight!
I kind of think it would be a good idea to have the LPB circuit powered to main power (left side of R50) for full voltage and to be decoupled from Bad Stone side. Splitting hairs, but I would do it if I had a choice
fuck smooth tone, fuck eric johnson - Seiche
User avatar
greenskull
Resistor Ronker
 
Posts: 261
Joined: 03 Jul 2007, 23:47
Has thanked: 37 times
Have thanks: 9 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Barcode » 16 Feb 2011, 00:06

greenskull wrote:Thanks Duckman, I will give it a shot tonight!
I kind of think it would be a good idea to have the LPB circuit powered to main power (left side of R50) for full voltage and to be decoupled from Bad Stone side. Splitting hairs, but I would do it if I had a choice

I would as well, as the lower the headroom the sooner the LPB will clip, though the difference in this case is probably negligable.
User avatar
Barcode
Diode Debunker
 
Posts: 821
Joined: 27 Sep 2007, 18:03
Has thanked: 14 times
Have thanks: 35 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Duckman » 16 Feb 2011, 07:33

No guys, thank you for your patience.
I agree with give full power to the LPB, just to get that little difference on your favor.
User avatar
Duckman
Opamp Operator
 
Posts: 1512
Joined: 20 May 2009, 02:45
Has thanked: 368 times
Have thanks: 126 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby timbo_93631 » 18 Feb 2011, 02:20

Got mine working today! Q1 was a match orientation-wise to the silkscreen, and I used 2N5088's that I bought from smallbear FWIW. When I drilled the enclosure I was going to lay the pedal out in "landscape" format with 3 knobs along the top edge and a 3PDT to go between vibrato and phase shift and an effect on/off 3PDT. This would have been fine but would have left no room for a battery so I decided to build it as a 2 knob with just phase shift and forego the vibrato by jumpering the SW1A and SW1B pads. After buttoning it up and playing with it for 2 minutes, my son decided to short the backside of the PCB to ground with a screwdriver through one of the unused holes and blew IC1. He's 20 months old, I am kinda proud he could blow something up at such an early age! Sounds great, but I think I am gonna get a DD enclosure for it and work out all the mods and prevent future suprises through the extra "ventilation" holes on top.
You do not have the required permissions to view the files attached to this post.
"I wish to be in the situation of non killing my balls bills, and life surprises." -Sinner
"Everyone gets their shorts in a twist over who polished the fenders. No one cares about who designed the engine..." -DougH
User avatar
timbo_93631
Solder Soldier
 
Posts: 247
Joined: 04 Mar 2010, 18:36
Location: Fresno, Ca
Has thanked: 21 times
Have thanks: 33 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Tonetweaker » 22 Feb 2011, 03:32

I'm still waiting for my boards.
In Soviet Russia, dirt box fucks YOU!! ~ Seiche
User avatar
Tonetweaker
Resistor Ronker
 
Posts: 287
Joined: 27 Dec 2010, 07:09
Location: South of Heaven
Has thanked: 25 times
Have thanks: 59 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Tonetweaker » 22 Feb 2011, 07:04

Apologies to Marcus. I just found his e-mail in my spam folder. Boards are on the way. I'm looking forward to giving this build a try once things settle down a bit. :thumbsup
In Soviet Russia, dirt box fucks YOU!! ~ Seiche
User avatar
Tonetweaker
Resistor Ronker
 
Posts: 287
Joined: 27 Dec 2010, 07:09
Location: South of Heaven
Has thanked: 25 times
Have thanks: 59 times

Re: Group buy of EH Bad Stone Phase Shift boards

Postby Barcode » 28 Feb 2011, 23:23

Well, now this is odd. My Bad Stone works great on it's own dedicated 12v wall-wart, but when I run it on the daisy from my one-spot, it's only making a faint misbiased sound. I thought maybe it required more current draw than I had available, but I'm only running 8 pedals on the chain including this one and the one-spot is supposed to carry 1 to 20 pedals (1700mA available current). Thoughts? I wonder if I forgot to change the resistor at r50 back to the stock value...
User avatar
Barcode
Diode Debunker
 
Posts: 821
Joined: 27 Sep 2007, 18:03
Has thanked: 14 times
Have thanks: 35 times

PreviousNext

Return to Parts Sourcing & Trading

Who is online

Users browsing this forum: No registered users and 1 guest