Page 1 of 2

Ross - Stereo Delay

PostPosted: 21 Nov 2007, 00:07
by analogguru
Here some guts:
http://cgi.ebay.com/Ross-Stereo-Delay-a ... dZViewItem

$90,-- seems to be a bargain for three SAD 1024A inside - socketed.
Looks really nice, anyone has more info ?

analogguru

PostPosted: 21 Nov 2007, 15:54
by Dirk_Hendrik
http://www.dirk-hendrik.com/temp/ross_delayschem.jpg

(and apart from a delay it's a crash course in switched capacitor filtering!)

PostPosted: 21 Nov 2007, 16:20
by junkwork

PostPosted: 21 Nov 2007, 16:25
by Dirk_Hendrik
They should be....

The one I've posted is the factory one.

PostPosted: 21 Nov 2007, 23:06
by Stephengiles
It's my drawing of the factory one, drawn in Excel, so there may be mistakes :wink:

It was lasted saved on 12 Feb 2004.

PostPosted: 22 Nov 2007, 00:23
by analogguru
Thanks !!!! cool....

That´s how an analog-delay should look like ...with clock-dependent LowPass-Filters...yeah

Now we start with real electronics.... apart from simple fuzzboxes. :lol:

analogguru

PostPosted: 22 Nov 2007, 10:23
by Dirk_Hendrik
Stephengiles wrote:It's my drawing of the factory one, drawn in Excel, so there may be mistakes :wink:

It was lasted saved on 12 Feb 2004.


Which is quite a piece of reverse engineering. Respect!

@ AG,
You may be right with the clocked filters. However, the one I had on my bench 2 yrs ago and set up to the exact Ross specs after repair was far from the best analog delay's I've heard.

Re: Ross - Stereo Delay

PostPosted: 30 Jul 2008, 05:42
by jonnyxjuturna
I have one of these. It's certainly an interesting beast

Re: Ross - Stereo Delay

PostPosted: 01 Aug 2008, 10:20
by DiscoFreq
I just received a Ross Flanger a few days ago

Re: Ross - Stereo Delay

PostPosted: 01 Aug 2008, 23:06
by rs
Can anyone post some gut shots?
Thanks.

Ross stereo delay board scan

PostPosted: 20 Oct 2008, 00:38
by nawduder
I'm making a simple repair on one of these monsters and am no good with schematics.
I found the problem: some of the wires between the board, the stereo switch, a pot and a 1/4" jack were knocked loose.
I need a photo that clearly illustrates which wires from the board go to which switch/pot/jack

I'd really appreciate it.
oh, and this is my first post

Re: Ross - Stereo Delay

PostPosted: 20 Oct 2008, 18:49
by nawduder
rs wrote:Can anyone post some gut shots?
Thanks.


This is what I'm looking for as well.

Re: Ross - Stereo Delay

PostPosted: 27 Dec 2009, 20:47
by canbaz
This delay is stereo, but there is a signal loss if we don't use it stereo. The original signal (not the delayed) is quieter and has much less low end. Using it stereo with a second amp solves the problem but i want to use it mono. How can i get rid off this signal loss? Any ideas ?

Re: Ross - Stereo Delay

PostPosted: 28 Dec 2009, 14:44
by Dirk_Hendrik
Got your PM.

Gotta look into this when I'm home again and not behind a laptop......

Re: Ross - Stereo Delay

PostPosted: 28 Mar 2010, 20:09
by SPeter
Hi all, sorry for reviving this old thread!
Reason:Found accidently found this gut on the net.
Web page(scroll down to see it):
http://blogs.myspace.com/mrbluetone
:)

Re: Ross - Stereo Delay

PostPosted: 28 Mar 2010, 22:17
by analogguru

Re: Ross - Stereo Delay

PostPosted: 28 Mar 2010, 22:30
by borislavgajic
thanks for info........

please can someone post schematic again?......those links are not working :cry:

cheers

Boris

Re: Ross - Stereo Delay

PostPosted: 29 Mar 2010, 00:34
by SPeter

Re: Ross - Stereo Delay

PostPosted: 29 Mar 2010, 00:52
by SPeter
Here they are!
Enjoy!
:D

Re: Ross - Stereo Delay

PostPosted: 14 May 2012, 05:24
by pinkjimiphoton
any chance of a reup? since the server issues a few months ago, a lot of the attachments are gone.