Monoprice 15 watt tube amp problems

Tube or solid-state, this section goes to eleven!

Monoprice 15 watt tube amp problems

Postby chuckusa » 06 May 2018, 22:15

So I got this amp, its a Monoprice 15 watt tube amp thats suppose to be modeled just like the Laney Cub12R I think.

I got the schematic for it. I was just wondering if anyone could help me ID this resettable fuse. And where can I find a replacement?

Laney calls it Laney PN 007390
the schematic also calls it PTC6.0

I looked the part up on ebay and found one that calls it a pollyswitch resettable 30V 6A fuse.

Is that what this part is? It was just jumpered when I got it. I want to replace the jump wire with the correct part. What do you guys think?
You do not have the required permissions to view the files attached to this post.
chuckusa
 
Posts: 18
Joined: 17 Apr 2018, 06:28
Has thanked: 0 time
Have thanks: 1 time

Re: Monoprice 15 watt tube amp problems

Postby chuckusa » 07 May 2018, 01:49

So the story went this amp was plugged in and running when a hair dryer was plugged into the same socket outlet and something in the amp popped.

From what I can tell after the amp popped,

these things were attempted to be replaced:

R2 and R12
F1 PTC6.0
250v glass fuse

What do you guys think? How bad is she? Will she live? Lol...

What I want to know is where can I find the two replacement fusible resistors and are they just plain ole 1/2 watt fusible 1k resistors?
what is that part thats been replaced with the jump wire, is it called a PTC6.0 resettable fuse? Where can I find one?

Where can I get these 3 items from? and whats their exact name and values ect, so I know im getting the right stuff....

Please refer to the pictures underlining info for details on each component.
You do not have the required permissions to view the files attached to this post.
chuckusa
 
Posts: 18
Joined: 17 Apr 2018, 06:28
Has thanked: 0 time
Have thanks: 1 time

Re: Monoprice 15 watt tube amp problems

Postby chuckusa » 07 May 2018, 04:05

I found the what I believe is a resettable fuse.

It came from where that jump wire is located.
So with the right mentioned parts replaced, do you guys think this amp will come back to life?

Im wondering if R2 and R12 are 1k half watt fusible resistors
and if F1 is a 30v 6A resettable fuse.

I want to replace these parts then pop a new glass fuse in her and see if she boots up lol
You do not have the required permissions to view the files attached to this post.
chuckusa
 
Posts: 18
Joined: 17 Apr 2018, 06:28
Has thanked: 0 time
Have thanks: 1 time

Re: Monoprice 15 watt tube amp problems

Postby chuckusa » 07 May 2018, 19:46

Oh yea also it wasnt a hair dryer that was plugged in, it was an old electric heater.
chuckusa
 
Posts: 18
Joined: 17 Apr 2018, 06:28
Has thanked: 0 time
Have thanks: 1 time

Re: Monoprice 15 watt tube amp problems

Postby chuckusa » 08 May 2018, 20:58

Sys mods please delete this entire thread, thanks. Sorry.

For this message the author chuckusa has received thanks:
teleK (12 May 2018, 21:05)
chuckusa
 
Posts: 18
Joined: 17 Apr 2018, 06:28
Has thanked: 0 time
Have thanks: 1 time

Re: Monoprice 15 watt tube amp problems

Postby modman » 15 Jun 2018, 11:03

chuckusa wrote:Sys mods please delete this entire thread, thanks. Sorry.

Why? This thread could help out others in the future...
Would be nice to share the schemtic too


Link


http://www.epiphonetalk.com/threads/nad ... 1815.1562/
You do not have the required permissions to view the files attached to this post.
"The whole point of diy is diy. It's not dsoiyathodtr - do some of it yourself and then have others do the rest" (paulc)

For this message the author modman has received thanks: 2
mojah63 (18 Nov 2018, 20:40), Nocentelli (15 Jun 2018, 12:55)
User avatar
modman
a d m i n
 
Posts: 4301
Joined: 19 Jun 2007, 17:57
Has thanked: 3108 times
Have thanks: 549 times


Return to Amplifiers

Who is online

Users browsing this forum: Google [Bot] and 5 guests