MEC WARWICK 3 BAND EQ RF ISSUE

Pickups, wiring schemes, switch techniques and onboard active electronics for guitars

MEC WARWICK 3 BAND EQ RF ISSUE

Postby darmstat » 30 Jan 2016, 15:45

I have a MEC / WARWICK 3 band bass on board eq and it has an issue. when i plug in my bass guitar the active system has a lot of noise and RF interference. the signal sounds weak when compared to the passive sound? I replaced the battery and i do not see any wires disconnected from the circuit. Any help on this would be appreciated.
darmstat
Breadboard Brother
 
Posts: 90
Joined: 06 Feb 2011, 19:15
Has thanked: 0 time
Have thanks: 40 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby bajaman » 30 Jan 2016, 20:29

first check the jack socket, before replacing op amps
be kind to all animals - especially human beings
User avatar
bajaman
Old Solderhand
 
Posts: 4102
Joined: 26 Jun 2007, 22:18
Location: New Brighton, Christchurch, NZ
Has thanked: 343 times
Have thanks: 809 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby darmstat » 30 Jan 2016, 22:32

here are the voltages arcoss the 2 op-amps

tl064
pin 1 4.52 v
pin 2 4.45 v
pin 3 3.78 v
pin 4 9.70 v
pin 5 4.48 v
pin 6 4.48 v
pin 7 4.47 v
pin 8 4.58v
pin 9 4.57 v
pin 10 4.54 v
pin 11 0
pin 12 4.30 v
pin 13 4.54 v
pin 14 4.54 v


tlo62

pin 1 .24 v
pin 2 .44 v
pin 3 .66v
pin 4 0
pin 5 4.30 v
pin 6 4.52 v
pin 7 4.52 v
pin 8 9.70 v
darmstat
Breadboard Brother
 
Posts: 90
Joined: 06 Feb 2011, 19:15
Has thanked: 0 time
Have thanks: 40 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby bajaman » 31 Jan 2016, 02:36

the voltages on the TL064 are good - the voltages on the TL062 do not look right to me but without seeing the schematic - hmmm. i would replace the TL062 and remeasure the voltages you should be getting approx 4.5 volts on pins 1,2, and 3.
be kind to all animals - especially human beings
User avatar
bajaman
Old Solderhand
 
Posts: 4102
Joined: 26 Jun 2007, 22:18
Location: New Brighton, Christchurch, NZ
Has thanked: 343 times
Have thanks: 809 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby darmstat » 31 Jan 2016, 02:41

I did the best i could to trace the circuit. Here is a schematic that i came up with.
darmstat
Breadboard Brother
 
Posts: 90
Joined: 06 Feb 2011, 19:15
Has thanked: 0 time
Have thanks: 40 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby darmstat » 31 Jan 2016, 02:47

I replaced the tlo62 with another one and still the same voltage readings? I tried yet another op-amp and still the same readings?
darmstat
Breadboard Brother
 
Posts: 90
Joined: 06 Feb 2011, 19:15
Has thanked: 0 time
Have thanks: 40 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby bajaman » 31 Jan 2016, 06:36

ok maybe that side of the op amp is not being used in the circuit - can not see the schematic
be kind to all animals - especially human beings
User avatar
bajaman
Old Solderhand
 
Posts: 4102
Joined: 26 Jun 2007, 22:18
Location: New Brighton, Christchurch, NZ
Has thanked: 343 times
Have thanks: 809 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby darmstat » 31 Jan 2016, 08:21

schematic
darmstat
Breadboard Brother
 
Posts: 90
Joined: 06 Feb 2011, 19:15
Has thanked: 0 time
Have thanks: 40 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby ggedamed » 31 Jan 2016, 09:52

You should double check the schematic for R1 - it doesn't make much sense to bias the + input through R3, then connect it to the ground.
Also, pins 10 and 5 of TL 064 should get some bias from somewhere.
Double also, you may have missed a resistor from pin 14 to pin 6 of TL064.
mw3_1.png

Other than that, nothing beats the old audio probe in debugging.

LATER EDIT: try to use easier to edit/view formats like png/gif/jpg, instead of pdf, when posting things not meant to be definitive.
You do not have the required permissions to view the files attached to this post.
User avatar
ggedamed
Resistor Ronker
 
Posts: 319
Joined: 21 Jun 2009, 12:43
Location: Bucharest, Romania
Has thanked: 138 times
Have thanks: 144 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby darmstat » 31 Jan 2016, 15:00

Maybe this one is a little better.
darmstat
Breadboard Brother
 
Posts: 90
Joined: 06 Feb 2011, 19:15
Has thanked: 0 time
Have thanks: 40 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby darmstat » 31 Jan 2016, 15:43

Better
darmstat
Breadboard Brother
 
Posts: 90
Joined: 06 Feb 2011, 19:15
Has thanked: 0 time
Have thanks: 40 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby ggedamed » 31 Jan 2016, 16:24

As Bajaman said, the first op amp has a problem. I would take out the TL062, then measure the voltage at pin 3 (in the op amp socket) and resistance from each of the pins 1 and 2 to ground. The voltage should be VR and pins 1 and 2 should have no connection to the ground. I'd also test the electrolytic caps around the op amp (C12 and the 1uF between R2 and ground).
User avatar
ggedamed
Resistor Ronker
 
Posts: 319
Joined: 21 Jun 2009, 12:43
Location: Bucharest, Romania
Has thanked: 138 times
Have thanks: 144 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby darmstat » 31 Jan 2016, 16:49

Thanks for the help. I bread boarded the last schematic and it works as it should.
darmstat
Breadboard Brother
 
Posts: 90
Joined: 06 Feb 2011, 19:15
Has thanked: 0 time
Have thanks: 40 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby darmstat » 31 Jan 2016, 18:19

I replaced C 2 and it works fine now?
darmstat
Breadboard Brother
 
Posts: 90
Joined: 06 Feb 2011, 19:15
Has thanked: 0 time
Have thanks: 40 times

Re: MEC WARWICK 3 BAND EQ RF ISSUE

Postby Serge75 » 02 Feb 2016, 11:44

Hallo, could someone please, post the pots for the circuits, where they connect and what value they are? I m not finding anything on google at the moment for a 3band mec preamp. I play on a warwick fortress one 5 and have always liked the sound, but I play it passive. I'd like to give it a try a the active middle cut. Thank you,
Sergio
Serge75
 
Posts: 7
Joined: 06 Sep 2012, 11:12
Has thanked: 0 time
Have thanks: 0 time


Return to Electric Guitar Rewiring

Who is online

Users browsing this forum: No registered users and 1 guest