Earthquaker Devices - Ghost Echo  [traced]

General documentation, gut shot, schematic links, ongoing circuit tracing, deep thoughts ... all about boutique stompboxes.

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 19 Apr 2013, 14:05

Which 1m Resistor (ie: R?) needs to be swapped with a 470R?

I'm going to try this tonight and see if I get to unity
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 19 Apr 2013, 14:13

Nevermind - I saw r21 - i need to use my eyeballs as my wife always tells me
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 19 Apr 2013, 22:09

And now I've freaking broken the brick somehow when de-soldering R21 - not sure if it's even worth trying this build again
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

Re: Earthquaker Devices Ghost Echo [guts]

Postby Motter » 19 Apr 2013, 22:48

If anyone wants to double check my resistor values from the other photos, here are the labelled components.

Image
Motter
Breadboard Brother
 
Posts: 107
Joined: 24 Aug 2012, 19:02
Location: New Orleans
Has thanked: 19 times
Have thanks: 73 times

Re: Earthquaker Devices Ghost Echo [guts]

Postby kodiakklub » 19 Apr 2013, 23:28

nativetrash wrote:And now I've freaking broken the brick somehow when de-soldering R21 - not sure if it's even worth trying this build again

DON'T GIVE UP!! i fear i may have fried my brick as well, but i will be buying a new one if i did.

@motter: i personally think the circuit was perfect except for the 1M/470 debacle. i will switch back the 10k/22k and hope that it works better than originally. i dont think theres anything more to fix on this circuit.
kodiakklub
 
Posts: 16
Joined: 26 May 2012, 02:59
Has thanked: 1 time
Have thanks: 10 times

Re: Earthquaker Devices Ghost Echo [guts]

Postby kodiakklub » 20 Apr 2013, 20:41

well i switched the 10k/22k back to the orig schem spec but replaced the 1M w/ a 470. its extremely close to unity gain now, but i ruined something(s) in the process. i know i tore up some pads and traces for the brick. hope i didnt fry the brick. its still only passing a clean uneffected signal bypassed or engaged. very odd. gonna etch another board and try again.

and i reccommend this regulator instead of the wimpy little TO92 one: http://www.taydaelectronics.com/lm7805-l7805-7805-voltage-regulator-ic-5v-1-5a.html
good for 1.5A! has a heatsink. should be bullet proof.
kodiakklub
 
Posts: 16
Joined: 26 May 2012, 02:59
Has thanked: 1 time
Have thanks: 10 times

Re: Earthquaker Devices Ghost Echo [guts]

Postby kodiakklub » 20 Apr 2013, 20:46

updated schemo:
Image

For this message the author kodiakklub has received thanks:
Intripped (27 Sep 2014, 13:27)
kodiakklub
 
Posts: 16
Joined: 26 May 2012, 02:59
Has thanked: 1 time
Have thanks: 10 times

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 26 Apr 2013, 16:40

So can we confirm that changing the resistor brought this back up to unity close enough that it would be worth purchasing another reverb brick and trying again?
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

Re: Earthquaker Devices Ghost Echo [guts]

Postby kodiakklub » 26 Apr 2013, 17:37

absolutely. changing the 1M to 470R is damn near unity. i will be building another very soon myself.
kodiakklub
 
Posts: 16
Joined: 26 May 2012, 02:59
Has thanked: 1 time
Have thanks: 10 times

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 26 Apr 2013, 21:01

Sweet! I'm going to etch another board & order another brick & give this a 2nd try
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 06 May 2013, 20:03

I finally got my new reverb brick so I'm going to attempt to have this working tonight, fingers crossed!
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 07 May 2013, 00:21

Now I've got a problem that's different - I just get a clicking when I turn the effect on - any idea what is wrong?
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

Re: Earthquaker Devices Ghost Echo [guts]

Postby kodiakklub » 07 May 2013, 00:44

can you try a different 2399 chip? perhaps that is fried? have you metered the regulators to make sure they are putting out 5V?
kodiakklub
 
Posts: 16
Joined: 26 May 2012, 02:59
Has thanked: 1 time
Have thanks: 10 times

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 07 May 2013, 12:47

I can try a different chip - I'm using the other reg chips with heat sink - is the flat side still the flat side in their orientation?
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 07 May 2013, 12:59

It's a constant click click click click
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 07 May 2013, 15:36

I was an idiot and didn't socket my ICs this time around so I'm likely going to build this one last time from scratch & use the original regulators i used before & socket the ICs - luckily I desoldered my reverb brick without any problems this time
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

Re: Earthquaker Devices Ghost Echo [guts]

Postby Govmnt_Lacky » 07 May 2013, 17:27

nativetrash wrote:I was an idiot and didn't socket my ICs this time around so I'm likely going to build this one last time from scratch & use the original regulators i used before & socket the ICs - luckily I desoldered my reverb brick without any problems this time


Recommend using ALL new parts (other than the brick of course)

New ICs, new regulators, socket everything! :applause:
Govmnt_Lacky
Resistor Ronker
 
Posts: 380
Joined: 24 Mar 2011, 14:00
Has thanked: 11 times
Have thanks: 42 times

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 13 May 2013, 21:38

Rebuilt & socketed everything and the third time was indeed a charm! Works and sounds great.

Thanks to everyone who helped!

For this message the author nativetrash has received thanks:
Motter (13 May 2013, 22:25)
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

Re: Earthquaker Devices Ghost Echo [guts]

Postby Motter » 13 May 2013, 22:26

Great job. Thanks for verifying, sorry about the initial mistakes in my trace.
Motter
Breadboard Brother
 
Posts: 107
Joined: 24 Aug 2012, 19:02
Location: New Orleans
Has thanked: 19 times
Have thanks: 73 times

Re: Earthquaker Devices Ghost Echo [guts]

Postby nativetrash » 16 May 2013, 17:52

I used it once to test and then after boxing up I get sound when the effect is engaged but no effect at all, just a slightly different sound of my bypass signal. I'm assuming that the chip perhaps fried from too much voltage? Any other ideas?
nativetrash
 
Posts: 18
Joined: 08 Oct 2012, 17:07
Has thanked: 0 time
Have thanks: 1 time

PreviousNext

Return to Boutique Stompboxes dissected...

Who is online

Users browsing this forum: Alex Frias, foltona, n0bchan, willwaush and 6 guests