Muff problems

Frequent questions about dead or faulty pedals. Whether you repair, mod or build pedals, debugging is important. Threads about general debugging problems irrespective of the circuit involved...

Muff problems

Postby Sokka06 » 28 Sep 2013, 20:26

So I just finished putting together my first kit. It's a Triangle Muff 2nd edition from Musikding.de aaand it doesn't work.

When I turn it on the LED lights up, but only hum comes through whether it's on or off.

Here are the parts list, wiring layout and schematics:
http://diy.musikding.de/wp-content/uplo ... dbomde.pdf
http://diy.musikding.de/wp-content/uplo ... ffwire.pdf
http://diy.musikding.de/wp-content/uplo ... schalt.pdf

And here some pictures:
http://s777.photobucket.com/user/Sokka0 ... iangleMuff

I'm kinda thinking it has something to do with the wires, because I was pretty sleepy when I was soldering them and I had to resolder some wires a few times, because I soldered them in the wrong place.

I do own a multimeter, but I have no idea how to use it other than checking the pots and transistors.

Any thoughts?
Sokka06
 
Posts: 8
Joined: 12 Apr 2012, 13:14
Has thanked: 1 time
Have thanks: 0 time

Re: Muff problems

Postby galmar » 29 Sep 2013, 10:20

Hum may come from your guitar, a ground loop or through the power supply. Did you power it up with a battery or an external DC voltage?

Check your wiring again, and I must admit that your soldering seems a bit lazy. :) The led lighting up means that it is properly wired through the switch.

Check for cold solder joints and verify again that you have properly wired up everything. Saying that, use your DVM to check that each connection is a good connection. It may indicate a weird measurement and save you some time. And answer the first line. :)
galmar
 
Posts: 47
Joined: 08 Mar 2011, 17:27
Has thanked: 2 times
Have thanks: 10 times

Re: Muff problems

Postby Sokka06 » 29 Sep 2013, 11:10

I powered it with a Visual Sound 1 Spot.

I'll check the wiring and the solder joints :)
Sokka06
 
Posts: 8
Joined: 12 Apr 2012, 13:14
Has thanked: 1 time
Have thanks: 0 time

Re: Muff problems

Postby Sokka06 » 29 Sep 2013, 19:18

I checked the wiring today with my multimeter set on the resistance mode and I didn't see anything odd.

I also bent the pins on some of the BC549B transistors pretty badly when I was trying to put them in the first time. Could there be something wrong with them?

I'll try to check the solder joints tomorrow.
Sokka06
 
Posts: 8
Joined: 12 Apr 2012, 13:14
Has thanked: 1 time
Have thanks: 0 time

Re: Muff problems

Postby galmar » 30 Sep 2013, 10:15

How loud is the hum you experience?

Maybe it is because of a ground loop and is amplified by your amp, or the gain stages work correctly and it comes from your power supply. Or a combination of these.

When you switch on, do you get additional hiss noise, or just hum?
galmar
 
Posts: 47
Joined: 08 Mar 2011, 17:27
Has thanked: 2 times
Have thanks: 10 times

Re: Muff problems

Postby Sokka06 » 30 Sep 2013, 13:26

I won't get home until thursday to make sure, but the last time I tried it no guitar sound came through at all and all I heard was hum whether it was on or off and the hum also seemed to "change" slightly when I turned the Sustain knob.
Sokka06
 
Posts: 8
Joined: 12 Apr 2012, 13:14
Has thanked: 1 time
Have thanks: 0 time

Re: Muff problems

Postby Sokka06 » 04 Oct 2013, 19:09

OK, the hum does get somewhat louder when turn up the Volume and the Sustain knob. There's also some scratching sound and pops when I turn the Tone knob.
Sokka06
 
Posts: 8
Joined: 12 Apr 2012, 13:14
Has thanked: 1 time
Have thanks: 0 time

Re: Muff problems

Postby galmar » 11 Oct 2013, 13:44

Well looking at your pictures I don't like your solder work. Almost no joint is shiny or has a pyramid shape.

Also, your pots' solder joints don't seem well to me.

I don't know, personally I would solder everything again with care, properly.

Before you do that, give us some DC voltages. Vc, Vb, Ve DC voltages, plus DC reading of your supply on the pcb.

And we will see. :)
galmar
 
Posts: 47
Joined: 08 Mar 2011, 17:27
Has thanked: 2 times
Have thanks: 10 times

Re: Muff problems

Postby Sokka06 » 14 Oct 2013, 19:40

Could you tell me how to do that or link to a some kind of a guide?

As I said, I'm pretty new to this stuff :D
Sokka06
 
Posts: 8
Joined: 12 Apr 2012, 13:14
Has thanked: 1 time
Have thanks: 0 time

Re: Muff problems

Postby galmar » 14 Oct 2013, 21:20

Do you have a voltmeter?
galmar
 
Posts: 47
Joined: 08 Mar 2011, 17:27
Has thanked: 2 times
Have thanks: 10 times

Re: Muff problems

Postby Sokka06 » 15 Oct 2013, 07:26

I have a DMM. It's pretty much the same thing, right?
Sokka06
 
Posts: 8
Joined: 12 Apr 2012, 13:14
Has thanked: 1 time
Have thanks: 0 time

Re: Muff problems

Postby galmar » 15 Oct 2013, 10:18

I assume you mean a DVM. Anyway, this is used to measure voltages, current and resistance.

As I said, you have to measure the voltages at each leg of your transistors. So the black tip of your DVM will go to circuit's ground (battery's black) and the red tip to each pin of each transistor. Tell us the voltage reading for collector, base and emitter for every transistor. If you don't know where each one is, look at datasheets. :)

EDIT: DMM stands for "Digital Multi Meter". Not a native speaker, forgive me. :)

For this message the author galmar has received thanks:
Sokka06 (13 Nov 2013, 20:35)
galmar
 
Posts: 47
Joined: 08 Mar 2011, 17:27
Has thanked: 2 times
Have thanks: 10 times

Re: Muff problems

Postby Sokka06 » 13 Nov 2013, 20:34

Sorry it took me so long to get back to you!

I got frustrated with the pedal and gave it to one of my dad's work friend so he could take a look at it, but he couldn't find out what was wrong with it.

Then I send it to a professional and he said one of the poles on the footswitch had been fried and the transistors were put round the wrong way. He also replaced some other parts with better ones plus redid the wiring and he says it works great now!

Thanks for all the help, though :applause:
Sokka06
 
Posts: 8
Joined: 12 Apr 2012, 13:14
Has thanked: 1 time
Have thanks: 0 time


Return to Debugging

Who is online

Users browsing this forum: No registered users and 0 guests

cron