??? indicator Led lights up - nothing plugged into input

Frequent question abouts LED and other types of diodes.

??? indicator Led lights up - nothing plugged into input

Postby mojoh » 08 Oct 2009, 07:53

im using this wiring for my builds
Image

however i only noticed the other day that with nothing plugged into the input/output jacks...the indicator still lights up when the foot switch is engaged (with battery is still in pedal)

does that mean that its draining battery life if the footswitch is dissengaged (with nothing plugged into input/output jacks?)
mojoh
Breadboard Brother
 
Posts: 148
Joined: 25 Aug 2009, 05:43
Has thanked: 0 time
Have thanks: 0 time

Re: ??? indicator Led lights up - nothing plugged into input

Postby bajaman » 08 Oct 2009, 10:42

If the battery black wire connects to the ring on the jack socket, (as in your picture) then this is impossible :shock: - check your wiring :!: - perhaps you have the earth and ring connections vice versa in the jack :wink:
bajaman
be kind to all animals - especially human beings
User avatar
bajaman
Old Solderhand
 
Posts: 4107
Joined: 26 Jun 2007, 22:18
Location: New Brighton, Christchurch, NZ
Has thanked: 349 times
Have thanks: 826 times

Re: ??? indicator Led lights up - nothing plugged into input

Postby mojoh » 11 Oct 2009, 07:24

turns out i had the sleve and ring vice versa.
hangs head in shame
mojoh
Breadboard Brother
 
Posts: 148
Joined: 25 Aug 2009, 05:43
Has thanked: 0 time
Have thanks: 0 time

Re: ??? indicator Led lights up - nothing plugged into input

Postby Scruffie » 11 Oct 2009, 14:49

Just for future reference I have had this happen with bad battery clips, with those cheap plastic ones they get squashed and I assume the red and black leads connect inside as squeezing it can allow the LED to come on even when wired correctly.
Scruffie
Opamp Operator
 
Posts: 1730
Joined: 13 Mar 2009, 18:59
Location: London.. ish, Uk
Has thanked: 27 times
Have thanks: 136 times

Re: ??? indicator Led lights up - nothing plugged into input

Postby mojoh » 12 Oct 2009, 05:16

Scruffie wrote:Just for future reference I have had this happen with bad battery clips, with those cheap plastic ones they get squashed and I assume the red and black leads connect inside as squeezing it can allow the LED to come on even when wired correctly.


i noticed this happened as well after i fixed the wiring...as im using small enclosures. problem was solved getting a T- styled battery clip...

ive learnt so much about making/mounting/wiring up pedals from just 3 pedal builds.

the wiring etc is pretty simple (even an idiot like me can sorta get a graps like it) but i think making a gig worthy professional pedal is an art itself.
mojoh
Breadboard Brother
 
Posts: 148
Joined: 25 Aug 2009, 05:43
Has thanked: 0 time
Have thanks: 0 time

Re: ??? indicator Led lights up - nothing plugged into input

Postby Merry Browen » 05 Jul 2012, 04:29

perhaps you have the earth and ring connections vice versa in the jack. :)







--------------------
led downlight
LED Fluorescent
led strip lights
Merry Browen
 
Posts: 1
Joined: 05 Jul 2012, 04:25
Has thanked: 0 time
Have thanks: 0 time


Return to Diodes & LEDs

Who is online

Users browsing this forum: No registered users and 0 guests